My 62 Lincoln Continental

Discussion about Lincoln
Car restoration projects. This is not an all out engine section. Discuss whatever is of concern to your MEL car restoration project.
User avatar
Theo
Administrator
Administrator
Posts: 1179
Joined: Sun 21. Dec 2008, 14:10
Gender: male
Location: Berlin / Potsdam in Germany
Contact:

Re: My 62 Lincoln Continental

Post by Theo » Mon 20. Jun 2011, 13:16

BTW, the rubber hose which connects the valve cover to the air filter housing is providing the crank case with fresh clean air. Hey, tthat kick back was a good laugh to me. ;) Did you guys pour gas into the throttle just to make the start up work faster? ha Ha, that's common practice. I have done it several times but figured a better way to start up a long sitting car.

1. Disconnect the gas hose from the fuel pump and w. a cone prime the gas line w gas. Reconnect.

2. With a syringe and a needle from your local pharmacy fill up the carb's fuel bowls via the fuel bowl vent.

3. Push the gas pedal twice but very slooow.

4. Turn the key. The engine should start at the first turn.
Best regards
Theo
Admin

NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Mon 20. Jun 2011, 16:55

Theo wrote:Hey, tthat kick back was a good laugh to me. ;) Did you guys pour gas into the throttle just to make the start up work faster?
LOL, yes we did ;-) well, my dad did hehe. I replaced all the gaskets and rubber parts including the diaphragm on the accelerator pump, and it is pumping gas into the barrels just fine.
keithol wrote:Did you have compressed air to blow out passages ? Are check valves in place and free? If you do have a good shot of fuel every time you crack the throttle it may be that you don't have enough choke richness. If that is the case it will run fine after reaching operating temp.
I think you're right on the money with the choke richness. After getting it down in the parking garage, I noticed a radiator/cooling leak, although I don't know where it is, so apparrently the choke isn't getting any coolant running through it on the carb, and it's not self adjusting like it should be. We did blow out the passages with air, and as for the check valves, I'm afraid I don't know what that means... ;-(

According to the manual, stalling on a cold engine is caused by an incorrect fast idle screw adjustment, automatic choke adjustment, incorrect idle fuel mixture, and a couple others that I ruled out. From what you hear, is there any quick adjustments I can make to get this working properly, or is there a quick and easy way to test the automatic choke?

Thanks again guys. With your help, I know I'll get through this. ;-)

Cheers!

User avatar
Theo
Administrator
Administrator
Posts: 1179
Joined: Sun 21. Dec 2008, 14:10
Gender: male
Location: Berlin / Potsdam in Germany
Contact:

Re: My 62 Lincoln Continental

Post by Theo » Tue 21. Jun 2011, 01:18

NicSanford wrote: ....I noticed a radiator/cooling leak, although I don't know where it is, so apparently the choke isn't getting any coolant running through it on the carb, and it's not self adjusting like it should be. ......
Is your choke coolant operated? I'm not familiar with this particular carb. To me it looks like it is either operated by a hot air tube from the exhaust manifold or by an electric choke.
I personally prefer a manual choke.
NicSanford wrote:According to the manual, stalling on a cold engine is caused by an incorrect fast idle screw adjustment, automatic choke adjustment, incorrect idle fuel mixture, and a couple others that I ruled out. From what you hear, is there any quick adjustments I can make to get this working properly, or is there a quick and easy way to test the automatic choke?
Thanks again guys. With your help, I know I'll get through this. ;-)

Cheers!
I suggest to start with the choke and the idle screw.
Best regards
Theo
Admin

NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Tue 21. Jun 2011, 10:15

Theo wrote:Is your choke coolant operated?
Yeah it is a water powered choke. I too have never heard of one of these, but I did discover last night that the coil inside the choke that pushes the lever to move the choke plates was on the outside of the lever, and not pushing it at all. When I fixed the pisitioning of the coil and lever, I noticed that the choke plate was about half open, as it was still a little warm from starting earlier.

I'm gonna go check now to see if the choke is closed, and if it is, I think I fixed the problem, although I might have to adjust the fast idle screw a bit. I'll keep you posted...

NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Tue 21. Jun 2011, 11:57

I went out this morning to test the choke, and found that it had closed as I expected. When I put the choke housing back on the carb, I apparrently overlooked connecting the lever on the coil inside the choke housing. I hope I'm getting my carb terminology right. ;-)


NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Wed 22. Jun 2011, 00:34

Well, it looks like diagnosing and fixing the carburetor and choke fixed the problem. Just put a brand new battery in her today, and she fires up right away, idles a little high, and sounds great pumping her up a little. Drove her back up to the main parking lot to wait for my dad and the trailer. Even got to drive her about a half mile to the store and around to drive her up the trailer.

Now that the carb and motor are running strong, we'll be power washing under the hood, replacing all the hoses, and finishing the brakes. Here she is after getting her onto the trailer, and on her way out to my folks place. All is lookin good here. Just need a good detail, pound out dents, new wheels and tires, fix the vacuum powered door locks, and a new paint job, and she'll be clean enough for summer.

Damn, I can't wait! Here are some quick pics of the trip out to my folks house...
2011-06-21_18-07-00_444.jpg
After getting her up on the trailer...
2011-06-21_18-54-37_380.jpg
Dad driving away...
2011-06-21_20-38-21_765.jpg
Finally at the folks place for the good stuff...
Last edited by NicSanford on Mon 27. Jun 2011, 21:57, edited 1 time in total.

kimroddy1
Airman basic
Posts: 1
Joined: Wed 22. Jun 2011, 01:22
Gender: male

Re: My 62 Lincoln Continental

Post by kimroddy1 » Wed 22. Jun 2011, 01:25

Thanks for sharing such a wonderful post, this is all great information. thanks again!!! :)

Car Cleaning

User avatar
Theo
Administrator
Administrator
Posts: 1179
Joined: Sun 21. Dec 2008, 14:10
Gender: male
Location: Berlin / Potsdam in Germany
Contact:

Re: My 62 Lincoln Continental

Post by Theo » Wed 22. Jun 2011, 01:40

Good to see your project progressing fast. There's probably a lot left to be done. I wonder if your AC works fine.
You mentioned that the engine is idling high. You are aware that you can kick down the pedal to release the carb linkage fast idle setting to normal idle?
Anyway, keep up the good work and let us read your blog.
Best regards
Theo
Admin

NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Mon 27. Jun 2011, 17:03

Well it's been a while since my last post so I'm getting around to posting some updates. I spent a few days at my folks place last week and was able to get quite a bit of work done. Here's some video of our progress. I have to admit, although there were some bumps in the road, i'm excited to see how she's turning out. You can really see the quality of this interior with just a quick cleaning, and so far seems to be the hilight of the car...

Here's a video tour of the workspace after power washing the motor and engine compartment. Still some staining and deep grease we'll get with some Gunk degreaser... (NOTE: My lil helper, Murray bumped his noggin, so here he is hanging out with Dad after the accident. You can see the bump while saying hello in the video. Poor guy!)




I may not have mentioned before that when I bought the car, we discovered a pretty hefty trailor hitch welded onto the frame, along with a pretty advanced looking tow system that I recently discovered is hydraulically connected to the master cylinder. We've since removed the trailer hitch, but will still need to remove the control under the dash along with the wiring and brass hose connected through the firewall to the brake system. Here's some video of the tow hitch removal, interior after cleaning, and wiring of the electronic fuel pump...




Cutting up the tumor after removing it from the frame. I'm sure she's happy to have it gone, and starting to feel like her old self...




Post surgery report... Here she is after removal of the trailer hitch. We tore the frame a bit knocking of the brackets that were welded on, but shouldn't be too hard to fix...




After all the work in the videos, we took some time to degrease the inch of grease sitting on the motor, so she's a lot cleaner under the hood now. With the engine still a little wet, we tried turning it over to turn the fan for timing, and after trying the first time, the car wouldn't start at all. While getting out of the car, I caught my foot on the green rope I have my keys on, and broke the only key we had in half. Thankfully we found a new key cylinder and starter relay at NAPA for $28 total. After installing the new key cylinder, the car started up right away so whatever the problem was, it was fixed after giving it time to dry. I'm wondering now how we can make the ignition and door keys the same. Anybody know of an easy way to rekey the door locks?

NicSanford
Airman First Class
Airman First Class
Posts: 60
Joined: Wed 18. May 2011, 20:40
Gender: male
Music instruments you're playing: Keys, Saxophone, Clarinet, Drums, Bass

Re: My 62 Lincoln Continental

Post by NicSanford » Mon 27. Jun 2011, 17:32

And some pics of the interior after cleaning...
2011-06-23_15-26-33_385.jpg
Getting ready to fly...
2011-06-23_17-56-39_626.jpg
The dash...
2011-06-23_17-57-38_150.jpg
Driver's side...
2011-06-23_17-57-52_593.jpg
Passenger's side...
2011-06-23_18-28-17_158.jpg
The tumor...

Post Reply

Return to “Lincoln Cars Restoration Projects”

Who is online

Users browsing this forum: No registered users and 1 guest