Power steering issue

Discussion of MEL engine related topics only.
Post Reply
fhogeweg
Airman basic
Posts: 17
Joined: Wed 2. May 2018, 15:05
Gender: male
Music instruments you're playing: None

Power steering issue

Post by fhogeweg » Fri 16. Aug 2019, 15:29

Hello everyone,

I need your great help (again). My engine is finally running and my rebuild trans is also driving both forwards and rearward (clutches where glued together due to water in the trans).
Now my power steering (pump) is making a lot of noise. Wenn steering to the right there is quit a loud sound coming from the lower part of the engine. When I provide some pressure on the steering wheel to the right the sound is gone. If I loosen the steering wheel it slowly pulls to the left (not driving and with the engine at idle) and starts making the noise. It also keeps slowly keeps turning. Power steering is working without hesitation.
I took apart the pump and steering gear to give it a reseal and cleaning. Before that it was working perfect except for the leaks.

Hope to solve the problem as I still can’t drive the car now.... :(

Thanks, Ferdy

The Californian
Airman basic
Posts: 10
Joined: Thu 18. Jul 2019, 08:16
Gender: male
Music instruments you're playing: Violin,viola,piano and guitar.

Re: Power steering issue

Post by The Californian » Fri 16. Aug 2019, 20:50

Never heard of all that going on before.

Better find a shop that rebuilds those things and send them on over.

Might be something is just put back together wrong.

Good luck with it!

The Californian
Airman basic
Posts: 10
Joined: Thu 18. Jul 2019, 08:16
Gender: male
Music instruments you're playing: Violin,viola,piano and guitar.

Re: Power steering issue

Post by The Californian » Fri 16. Aug 2019, 20:54

'I took apart the pump and steering gear to give it a reseal and cleaning. Before that it was working perfect except for the leaks.'

Hate to say it but that looks like the problem.

Find a good manual and do it again.

Do one at a time maybe you will get lucky and pick right one!

Good luck!

fhogeweg
Airman basic
Posts: 17
Joined: Wed 2. May 2018, 15:05
Gender: male
Music instruments you're playing: None

Re: Power steering issue

Post by fhogeweg » Sun 18. Aug 2019, 12:51

Sorry to say, but I’m not look for advise on what I should have done. I live in Europe, and there are very few shops that really know something about USA cars, they ask absurd high prices and often it is still not good.

I rebuilt almost everything my self as I am an mechanic my self. A good friend (fellow mechanic) said there should be a problem in the steering gear on the high pressure side. He had a similar problem but with a ‘56 Cadillac and that (of course) has a different kind of steering gear.

Can someone point me in the right direction rather than say what it should have done?

Thanks

novetti
Airman basic
Posts: 9
Joined: Mon 22. Jan 2018, 18:56
Gender: male
Music instruments you're playing: Bass, Classical Guitar

Re: Power steering issue

Post by novetti » Wed 21. Aug 2019, 16:48

When you serviced your box, was there a chance you mounted it with the sector shaft indexed wrong in relationship with the recirculating ball fuse box? (out of the central position) ?

Do you have adjusted the sector shaft free play correctly? Is it binding (too tight)? or Too loose?

fhogeweg
Airman basic
Posts: 17
Joined: Wed 2. May 2018, 15:05
Gender: male
Music instruments you're playing: None

Re: Power steering issue

Post by fhogeweg » Sat 24. Aug 2019, 10:36

Hi novetti.

I saw in the manual that the valve spool could be adjusted and that could make the same kind of problem. I think it’s the same that you mentioned. If it is out of central position it keeps (a small amount of) pressure on the steering gear. So that could solve the issue. I’ll try to adjust on Monday.
Also the steering goes really smooth to one side, while I need to work just a bit harder the other way around.

Will let you know if I solved with this valve spool adjustment.

Thanks

fhogeweg
Airman basic
Posts: 17
Joined: Wed 2. May 2018, 15:05
Gender: male
Music instruments you're playing: None

Re: Power steering issue

Post by fhogeweg » Mon 26. Aug 2019, 14:39

Worked on the power steering today and kind of solved the problem. Why kind of... first it was turning itself to the left, and when I adjusted the nut on my steering gear it turend to the right. Been trying to get it levelled out in the center but that's not an easy think to do. You can't do it with the engine turning as the oil comes out and you will burn your hands against the exhaust!

No the noise is gone, but steering to the left is still much easier than to the right. Will have to work even more on it, but I'm sure this will fix my problem.

Thanks for thinking with me anyway, I appreciate it!

Post Reply

Return to “MEL Engine General Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests